import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(var\\s|)\\s*\\w+\\s+=\\s+require\\(\\'[\\w.\\/]*sass[\\w.\\/]*\\'\\);*\\s*";
final String string = "/** File Head **/\n\n"
+ "var StyleSheet = require('./stylesheet.scss');var test;\n"
+ "var test2 = require('lodash');\n"
+ "var another = require('../../scss/test');\n"
+ " styleSheet = require('stylesheet.scss'), styleSheet = require('stylesheet.sass')\n"
+ "StyleSheet = require('./stylesheet.scss');var test;\n"
+ "var common = require('common.js');\n\n"
+ "/** File Foot **/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}