# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(var\s|)\s*\w+\s+=\s+require\(\'[\w.\/]*sass[\w.\/]*\'\);*\s*"
test_str = ("/** File Head **/\n\n"
"var StyleSheet = require('./stylesheet.scss');var test;\n"
"var test2 = require('lodash');\n"
"var another = require('../../scss/test');\n"
" styleSheet = require('stylesheet.scss'), styleSheet = require('stylesheet.sass')\n"
"StyleSheet = require('./stylesheet.scss');var test;\n"
"var common = require('common.js');\n\n"
"/** File Foot **/")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.