const regex = /(var\s|)\s*\w+\s+=\s+require\(\'[\w.\/]*sass[\w.\/]*\'\);*\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(var\\s|)\\s*\\w+\\s+=\\s+require\\(\\\'[\\w.\\\/]*sass[\\w.\\\/]*\\\'\\);*\\s*', 'g')
const str = `/** File Head **/
var StyleSheet = require('./stylesheet.scss');var test;
var test2 = require('lodash');
var another = require('../../scss/test');
styleSheet = require('stylesheet.scss'), styleSheet = require('stylesheet.sass')
StyleSheet = require('./stylesheet.scss');var test;
var common = require('common.js');
/** File Foot **/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}