// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(var\s|)\s*\w+\s+=\s+require\(\'[\w.\/]*sass[\w.\/]*\'\);*\s*").unwrap();
let string = "/** File Head **/
var StyleSheet = require('./stylesheet.scss');var test;
var test2 = require('lodash');
var another = require('../../scss/test');
styleSheet = require('stylesheet.scss'), styleSheet = require('stylesheet.sass')
StyleSheet = require('./stylesheet.scss');var test;
var common = require('common.js');
/** File Foot **/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}