import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}-\\d{2}-\\d{2}\\\\t)(.*?)(\\[\\w{2}\\]\\\\t)";
final String string = "\\n2021-01-12\\tThis string is not needed [it]\\tBad things\\tBad things\\n2021-01-12\\tThis string is also not needed [en]\\tBad things\\tBad things\\n2021-01-11\\tString 1 that is needed! [it]\\tString 1 that is needed! is repeated here\\tNot interesting here\\n2021-01-11\\tString 2 that is needed [fr]\\tString 2 that is needed is repeated here\\tUnnecessary string\\n2021-01-11\\tString 3 that is needed... [ru]\\tString 3 that is needed... is repeated here\\tAnother part we're not interested in";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}