// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4}-\d{2}-\d{2}\\t)(.*?)(\[\w{2}\]\\t)").unwrap();
let string = "\\n2021-01-12\\tThis string is not needed [it]\\tBad things\\tBad things\\n2021-01-12\\tThis string is also not needed [en]\\tBad things\\tBad things\\n2021-01-11\\tString 1 that is needed! [it]\\tString 1 that is needed! is repeated here\\tNot interesting here\\n2021-01-11\\tString 2 that is needed [fr]\\tString 2 that is needed is repeated here\\tUnnecessary string\\n2021-01-11\\tString 3 that is needed... [ru]\\tString 3 that is needed... is repeated here\\tAnother part we're not interested in";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}