import re
regex = re.compile(r"(\d{4}-\d{2}-\d{2}\\t)(.*?)(\[\w{2}\]\\t)", flags=re.MULTILINE)
test_str = "\\n2021-01-12\\tThis string is not needed [it]\\tBad things\\tBad things\\n2021-01-12\\tThis string is also not needed [en]\\tBad things\\tBad things\\n2021-01-11\\tString 1 that is needed! [it]\\tString 1 that is needed! is repeated here\\tNot interesting here\\n2021-01-11\\tString 2 that is needed [fr]\\tString 2 that is needed is repeated here\\tUnnecessary string\\n2021-01-11\\tString 3 that is needed... [ru]\\tString 3 that is needed... is repeated here\\tAnother part we're not interested in"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")