const regex = /(\d{4}-\d{2}-\d{2}\\t)(.*?)(\[\w{2}\]\\t)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}-\\d{2}-\\d{2}\\\\t)(.*?)(\\[\\w{2}\\]\\\\t)', 'gm')
const str = `\\n2021-01-12\\tThis string is not needed [it]\\tBad things\\tBad things\\n2021-01-12\\tThis string is also not needed [en]\\tBad things\\tBad things\\n2021-01-11\\tString 1 that is needed! [it]\\tString 1 that is needed! is repeated here\\tNot interesting here\\n2021-01-11\\tString 2 that is needed [fr]\\tString 2 that is needed is repeated here\\tUnnecessary string\\n2021-01-11\\tString 3 that is needed... [ru]\\tString 3 that is needed... is repeated here\\tAnother part we're not interested in`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}