$re = '/(\d{4}-\d{2}-\d{2}\\\\t)(.*?)(\[\w{2}\]\\\\t)/m';
$str = '\\n2021-01-12\\tThis string is not needed [it]\\tBad things\\tBad things\\n2021-01-12\\tThis string is also not needed [en]\\tBad things\\tBad things\\n2021-01-11\\tString 1 that is needed! [it]\\tString 1 that is needed! is repeated here\\tNot interesting here\\n2021-01-11\\tString 2 that is needed [fr]\\tString 2 that is needed is repeated here\\tUnnecessary string\\n2021-01-11\\tString 3 that is needed... [ru]\\tString 3 that is needed... is repeated here\\tAnother part we\'re not interested in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);