using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"session_state \((?<session_state>[^\)]+)\)";
string input = @"session_state (SYN, ACK)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}