re = /session_state \((?<session_state>[^\)]+)\)/
str = 'session_state (SYN, ACK)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end