$re = '/session_state \((?<session_state>[^\)]+)\)/';
$str = 'session_state (SYN, ACK)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);