using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w.-]+@([\w-]+)\.+\w{2,})";
string substitution = @"";
string input = @"user.name@domain.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}