re = /([\w.-]+@([\w-]+)\.+\w{2,})/
str = 'user.name@domain.com'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result