$re = '/([\w.-]+@([\w-]+)\.+\w{2,})/';
$str = 'user.name@domain.com';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;