const regex = /([\w.-]+@([\w-]+)\.+\w{2,})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w.-]+@([\\w-]+)\\.+\\w{2,})', '')
const str = `user.name@domain.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);