#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\A|\})(\s*)\{"
Local $sString = "a" & @CRLF & _
" {" & @CRLF & _
"color:black;" & @CRLF & _
"background-color:blue;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"{color:red}" & @CRLF & _
"<!-- TEST -->" & @CRLF & _
"" & @CRLF & _
"@media screen and (max-width:620px) {" & @CRLF & _
"/* TEST 2 */" & @CRLF & _
"a.test {color:blue;}" & @CRLF & _
"p[class="test2"] {color:green;}" & @CRLF & _
"}"
Local $sSubst = "$1.missing-selector {"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)