import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\A|\\})(\\s*)\\{";
final String string = "a\n"
+ " {\n"
+ "color:black;\n"
+ "background-color:blue;\n"
+ "}\n\n"
+ "{color:red}\n"
+ "<!-- TEST -->\n\n"
+ "@media screen and (max-width:620px) {\n"
+ "/* TEST 2 */\n"
+ "a.test {color:blue;}\n"
+ "p[class=\"test2\"] {color:green;}\n"
+ "}";
final String subst = "$1.missing-selector {";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}