re = /(?<=\A|\})(\s*)\{/m
str = 'a
{
color:black;
background-color:blue;
}
{color:red}
<!-- TEST -->
@media screen and (max-width:620px) {
/* TEST 2 */
a.test {color:blue;}
p[class="test2"] {color:green;}
}'
subst = '$1.missing-selector {'
result = str.sub(re, subst)
# Print the result of the substitution
puts result