$re = '/(?<=\A|\})(\s*)\{/m';
$str = 'a
{
color:black;
background-color:blue;
}
{color:red}
<!-- TEST -->
@media screen and (max-width:620px) {
/* TEST 2 */
a.test {color:blue;}
p[class="test2"] {color:green;}
}';
$subst = "$1.missing-selector {";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;