use strict;
my $str = 'a
{
color:black;
background-color:blue;
}
{color:red}
<!-- TEST -->
@media screen and (max-width:620px) {
/* TEST 2 */
a.test {color:blue;}
p[class="test2"] {color:green;}
}';
my $regex = qr/(?<=\A|\})(\s*)\{/mp;
my $subst = '$1.missing-selector {';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";