import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^[ \\t]{0,50}\\r?\\n){3}[ \\t]{0,10}(http:\\/\\/(?!www\\.)[^\\s\\/]{3,30})\\/([ucv])\\/([^\\s\\.]{3,60}\\.html?)\\S{0,10}[ \\t]{0,10}\\r?\\n(?:^[ \\t]{0,50}\\r?\\n){5,50}[^\\/]{1,100}\\b\\1\\/(?!\\2)[ucv]\\/\\3";
final String string = "\n\n\n"
+ "http://example.com/u/adadad.html\n\n\n\n\n\n"
+ "sdfsf http://example.com/v/adadad.html";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}