import re
regex = re.compile(r"(?:^[ \t]{0,50}\r?\n){3}[ \t]{0,10}(http:\/\/(?!www\.)[^\s\/]{3,30})\/([ucv])\/([^\s\.]{3,60}\.html?)\S{0,10}[ \t]{0,10}\r?\n(?:^[ \t]{0,50}\r?\n){5,50}[^\/]{1,100}\b\1\/(?!\2)[ucv]\/\3", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("\n\n\n"
"http://example.com/u/adadad.html\n\n\n\n\n\n"
"sdfsf http://example.com/v/adadad.html")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")