const regex = /(?:^[ \t]{0,50}\r?\n){3}[ \t]{0,10}(http:\/\/(?!www\.)[^\s\/]{3,30})\/([ucv])\/([^\s\.]{3,60}\.html?)\S{0,10}[ \t]{0,10}\r?\n(?:^[ \t]{0,50}\r?\n){5,50}[^\/]{1,100}\b\1\/(?!\2)[ucv]\/\3/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^[ \\t]{0,50}\\r?\\n){3}[ \\t]{0,10}(http:\\\/\\\/(?!www\\.)[^\\s\\\/]{3,30})\\\/([ucv])\\\/([^\\s\\.]{3,60}\\.html?)\\S{0,10}[ \\t]{0,10}\\r?\\n(?:^[ \\t]{0,50}\\r?\\n){5,50}[^\\\/]{1,100}\\b\\1\\\/(?!\\2)[ucv]\\\/\\3', 'im')
const str = `
http://example.com/u/adadad.html
sdfsf http://example.com/v/adadad.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}