import Foundation
let pattern = #"(?:^[ \t]{0,50}\r?\n){3}[ \t]{0,10}(http:\/\/(?!www\.)[^\s\/]{3,30})\/([ucv])\/([^\s\.]{3,60}\.html?)\S{0,10}[ \t]{0,10}\r?\n(?:^[ \t]{0,50}\r?\n){5,50}[^\/]{1,100}\b\1\/(?!\2)[ucv]\/\3"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://example.com/u/adadad.html
sdfsf http://example.com/v/adadad.html
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}