re = /(?:^[ \t]{0,50}\r?\n){3}[ \t]{0,10}(http:\/\/(?!www\.)[^\s\/]{3,30})\/([ucv])\/([^\s\.]{3,60}\.html?)\S{0,10}[ \t]{0,10}\r?\n(?:^[ \t]{0,50}\r?\n){5,50}[^\/]{1,100}\b\1\/(?!\2)[ucv]\/\3/im
str = '
http://example.com/u/adadad.html
sdfsf http://example.com/v/adadad.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end