#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<prefix1>\d{0,3}?)(?<threes1>\d{0,3})\/(?<prefix2>\d{0,3}?)(?=\d)(?<threes2>\d{0,3})"
Local $sString = "12345/1234 -> [12,345,1,234]" & @CRLF & _
"123456/789123 -> [123,456,789,123]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"0/1 -> [,,0,1]" & @CRLF & _
"123/132 -> [,123,,132]" & @CRLF & _
"1234/3 -> [1,234,,3]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")