re = /(?<prefix1>\d{0,3}?)(?<threes1>\d{0,3})\/(?<prefix2>\d{0,3}?)(?=\d)(?<threes2>\d{0,3})/
str = '12345/1234 -> [12,345,1,234]
123456/789123 -> [123,456,789,123]
0/1 -> [,,0,1]
123/132 -> [,123,,132]
1234/3 -> [1,234,,3]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end