import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<prefix1>\\d{0,3}?)(?<threes1>\\d{0,3})\\/(?<prefix2>\\d{0,3}?)(?=\\d)(?<threes2>\\d{0,3})";
final String string = "12345/1234 -> [12,345,1,234]\n"
+ "123456/789123 -> [123,456,789,123]\n\n\n"
+ "0/1 -> [,,0,1]\n"
+ "123/132 -> [,123,,132]\n"
+ "1234/3 -> [1,234,,3]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}