const regex = new RegExp('(?<prefix1>\\d{0,3}?)(?<threes1>\\d{0,3})\\/(?<prefix2>\\d{0,3}?)(?=\\d)(?<threes2>\\d{0,3})', 'g')
const str = `12345/1234 -> [12,345,1,234]
123456/789123 -> [123,456,789,123]
0/1 -> [,,0,1]
123/132 -> [,123,,132]
1234/3 -> [1,234,,3]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}