using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<prefix1>\d{0,3}?)(?<threes1>\d{0,3})\/(?<prefix2>\d{0,3}?)(?=\d)(?<threes2>\d{0,3})";
string input = @"12345/1234 -> [12,345,1,234]
123456/789123 -> [123,456,789,123]
0/1 -> [,,0,1]
123/132 -> [,123,,132]
1234/3 -> [1,234,,3]
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}