using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w]+[.][\w]+)*=*'{\#FVD([\d]+)\}";
string input = @"EQU.ST_CODLON='{#FVD242002}'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}