$re = '/([\w]+[.][\w]+)*=*\'{\#FVD([\d]+)\}/';
$str = 'EQU.ST_CODLON=\'{#FVD242002}\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);