const regex = new RegExp('([\\w]+[.][\\w]+)*=*\\'{\\#FVD([\\d]+)\\}', '')
const str = `EQU.ST_CODLON='{#FVD242002}'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}