using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\,[,^.]{0,}|^)(foobar)[,^.]{0,})";
string input = @"foobar,foobar123,abc,foo,bar,foObar,,,foobar,f,dfg,$foobar£,foobar";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}