// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:(?:\,[,^.]{0,}|^)(foobar)[,^.]{0,})").unwrap();
let string = "foobar,foobar123,abc,foo,bar,foObar,,,foobar,f,dfg,$foobar £,foobar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}