re = /(?:(?:\,[,^.]{0,}|^)(foobar)[,^.]{0,})/
str = 'foobar,foobar123,abc,foo,bar,foObar,,,foobar,f,dfg,$foobar£,foobar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end