package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:\,[,^.]{0,}|^)(foobar)[,^.]{0,})`)
var str = `foobar,foobar123,abc,foo,bar,foObar,,,foobar,f,dfg,$foobar£,foobar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}