#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][a-zA-Z]*(?:\s+[a-zA-Z]+)*'s(?!\S)"
Local $sString = "Amarok's Golovin's Road => Amarok's " & @CRLF & _
"Arkouna Dream's Elowin Engel's => Arkouna Dream's " & @CRLF & _
"Arkouna Dream's Elowin Engel's => Arkouna Dream's (in this case, I added a space after Engel's)" & @CRLF & _
"Liubov's Niagara => Liubov's " & @CRLF & _
"Urane Of Watson Lake => nothing" & @CRLF & _
"Of the mountain's Dog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")