import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][a-zA-Z]*(?:\\s+[a-zA-Z]+)*'s(?!\\S)";
final String string = "Amarok's Golovin's Road => Amarok's \n"
+ "Arkouna Dream's Elowin Engel's => Arkouna Dream's \n"
+ "Arkouna Dream's Elowin Engel's => Arkouna Dream's (in this case, I added a space after Engel's)\n"
+ "Liubov's Niagara => Liubov's \n"
+ "Urane Of Watson Lake => nothing\n"
+ "Of the mountain's Dog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}