# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Z][a-zA-Z]*(?:\s+[a-zA-Z]+)*'s(?!\S)"
test_str = ("Amarok's Golovin's Road => Amarok's \n"
"Arkouna Dream's Elowin Engel's => Arkouna Dream's \n"
"Arkouna Dream's Elowin Engel's => Arkouna Dream's (in this case, I added a space after Engel's)\n"
"Liubov's Niagara => Liubov's \n"
"Urane Of Watson Lake => nothing\n"
"Of the mountain's Dog")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.