import Foundation
let pattern = #"^[A-Z][a-zA-Z]*(?:\s+[a-zA-Z]+)*'s(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Amarok's Golovin's Road => Amarok's
Arkouna Dream's Elowin Engel's => Arkouna Dream's
Arkouna Dream's Elowin Engel's => Arkouna Dream's (in this case, I added a space after Engel's)
Liubov's Niagara => Liubov's
Urane Of Watson Lake => nothing
Of the mountain's Dog
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)