$re = '/^[A-Z][a-zA-Z]*(?:\s+[a-zA-Z]+)*\'s(?!\S)/m';
$str = 'Amarok\'s Golovin\'s Road => Amarok\'s
Arkouna Dream\'s Elowin Engel\'s => Arkouna Dream\'s
Arkouna Dream\'s Elowin Engel\'s => Arkouna Dream\'s (in this case, I added a space after Engel\'s)
Liubov\'s Niagara => Liubov\'s
Urane Of Watson Lake => nothing
Of the mountain\'s Dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);