#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!_|\d{3})(?!.*[a-z](?=.{1,4}$)[a-z\d_]*\.)[a-z\d_.]{5,32}$(?<!_)"
Local $sString = "valide" & @CRLF & _
"99valide" & @CRLF & _
"130nevalide" & @CRLF & _
"val_ide" & @CRLF & _
"_novalide_" & @CRLF & _
"valide.desk" & @CRLF & _
"" & @CRLF & _
"novalide...." & @CRLF & _
"novalide..." & @CRLF & _
"novalide.." & @CRLF & _
"novalide." & @CRLF & _
"novalide.z" & @CRLF & _
"novalide.zz" & @CRLF & _
"novalide.zzz" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"test.zzzz" & @CRLF & _
"valide.desk.test" & @CRLF & _
"test_.abc" & @CRLF & _
"a_________a" & @CRLF & _
"aaaaa_2.2a" & @CRLF & _
"aaaaa_2.2a."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")