const regex = /^(?!_|\d{3})(?!.*[a-z](?=.{1,4}$)[a-z\d_]*\.)[a-z\d_.]{5,32}$(?<!_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!_|\\d{3})(?!.*[a-z](?=.{1,4}$)[a-z\\d_]*\\.)[a-z\\d_.]{5,32}$(?<!_)', 'gm')
const str = `valide
99valide
130nevalide
val_ide
_novalide_
valide.desk
novalide....
novalide...
novalide..
novalide.
novalide.z
novalide.zz
novalide.zzz
test.zzzz
valide.desk.test
test_.abc
a_________a
aaaaa_2.2a
aaaaa_2.2a.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}