import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!_|\\d{3})(?!.*[a-z](?=.{1,4}$)[a-z\\d_]*\\.)[a-z\\d_.]{5,32}$(?<!_)";
final String string = "valide\n"
+ "99valide\n"
+ "130nevalide\n"
+ "val_ide\n"
+ "_novalide_\n"
+ "valide.desk\n\n"
+ "novalide....\n"
+ "novalide...\n"
+ "novalide..\n"
+ "novalide.\n"
+ "novalide.z\n"
+ "novalide.zz\n"
+ "novalide.zzz\n\n\n"
+ "test.zzzz\n"
+ "valide.desk.test\n"
+ "test_.abc\n"
+ "a_________a\n"
+ "aaaaa_2.2a\n"
+ "aaaaa_2.2a.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}