using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!_|\d{3})(?!.*[a-z](?=.{1,4}$)[a-z\d_]*\.)[a-z\d_.]{5,32}$(?<!_)";
string input = @"valide
99valide
130nevalide
val_ide
_novalide_
valide.desk
novalide....
novalide...
novalide..
novalide.
novalide.z
novalide.zz
novalide.zzz
test.zzzz
valide.desk.test
test_.abc
a_________a
aaaaa_2.2a
aaaaa_2.2a.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}