re = /^(?!_|\d{3})(?!.*[a-z](?=.{1,4}$)[a-z\d_]*\.)[a-z\d_.]{5,32}$(?<!_)/m
str = 'valide
99valide
130nevalide
val_ide
_novalide_
valide.desk
novalide....
novalide...
novalide..
novalide.
novalide.z
novalide.zz
novalide.zzz
test.zzzz
valide.desk.test
test_.abc
a_________a
aaaaa_2.2a
aaaaa_2.2a.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end