package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(?<TimeStamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d+)\]\s+\[(?<Level>\w+)\]\s+\[(?<Symbol>\S+)\]\s*(?<Message>.*)`)
var str = `[2025-11-25 09:03:04.409] [Info] [enso.rt.ga.server.SystemRpc] ...Successful`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}