$re = '/\[(?<TimeStamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d+)\]\s+\[(?<Level>\w+)\]\s+\[(?<Symbol>\S+)\]\s*(?<Message>.*)/m';
$str = '[2025-11-25 09:03:04.409] [Info] [enso.rt.ga.server.SystemRpc] ...Successful';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);